Lambda Sensors - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Lambda Sensors

Anyone know how to diagnose a faulty Lambda sensor? - Or is it a trip to the garage job?
Engine seems to be running a little lean - got 360 miles out of it for the last two tanks

Sponsored Links
Status: -
AO Silver Member
alfizta's Avatar
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,631
Images: 10
Re: Lambda Sensors

i also have the same question, cause i think i have a faulty lambda (strangely only causes me problems in hotter days) and would like to test it.

read some threads that when disconnecting it, the engine run/economy went better, pointing to lambda sensor as the problem.

don’t know if this works for every case, but i’m going to try it when i get the same running problems. also had some months with really poor fuel economy, but not sure if it was before the thermostat change, or the overuse of air conditioning...
alfizta is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

lambda , sensors

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome