cold weather problem. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-01-09 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: wrexham
Posts: 171
cold weather problem.

evening peeps, bit of a strange one this.... first thing in the morning, the last few days, when i turn the key, the engine starts and then the hazzards flash once and that's it. car is a bit slow to turn over but nothing to worry about. is this the first sign of a battery on the way out? ta. alarm is a cat1 toad by the way.
willis is offline  
Sponsored Links
Status: NEW ALFA! :D
AO Silver Member
SpiderMJ's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: -
Posts: 1,104
Images: 1
Re: cold weather problem.

Yes the battery is probably getting low on charge. Cold weather tends to expose a weak battery.

You can get tablets to drop into the battery with some water to help increase charge. You can also get overnight car battery chargers or trickle chargers which work well in the winter. Both are fairly cheap.
SpiderMJ is offline  
Status: -
AO Member
amancalledrob's Avatar
Join Date: Jan 2008
Location: United Kingdom
County: Kent
Posts: 435
Re: cold weather problem.

My car did this too. The hazards flash because the drain on the battery from starting the engine is so great that, when the battery's on it's way out, it interrupts power to the alarm, which is triggered by loss of power. My car eventually failed to start altogether, followed by a couple of unenthusiastic wails from the alarm. I bump started it (yes, I know this is naughty) and took it to Halfords, where they tested the battery and advised me it was beyond rescue. £90 later I've got a new one that's guaranteed for 5 years and the difference is amazing

There are 10 kinds of people in this world. Those that can read binary, and those who can't.

Driving: Vela Blue V6 Gtv 5spd, blue Momo leather

Gone but sorely, sorely missed:

Meteor Grey Gtv Lusso | 17" Teledials | Bilstein rear shocks | Ragazzon straight thru s/s centre exhaust | Some crappy Halfords air filter. Perfect condition and still 220bhp after 95k
amancalledrob is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cold , problem , weather

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome