GTV 2TS squealing noise?????? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
GTV 2TS squealing noise??????


I recently have (yesterday 27 November) my cambelt, balance tensioner, auxiliary belt and tensioner changed but now in the mornings I get squealing noise. Is this something I should be worried about? Is it beause its all new? Once it is running about 30 mins or so it goes away but every morning I get a squealing noise.
Sponsored Links
Status: Alfaless
AO Member
mossawi's Avatar
Join Date: Apr 2008
Location: United Arab Emirates
County: Dubayy
Posts: 604
Images: 28
Re: GTV 2TS squealing noise??????

Auxilary belt may not be tight enough. Its no big deal but take it back and get them to fix it. Thats my suggesiton ;-)
mossawi is offline  
Status: - Update
Posts: n/a
Re: GTV 2TS squealing noise??????

thank you, will do
Status: -
AO Member
GTV Rob's Avatar
Join Date: Nov 2007
Location: United Kingdom
County: West Midlands
Posts: 953
Images: 1

Member car:


Re: GTV 2TS squealing noise??????

Yea, get it sorted. Mine squeals for literally about 5-10 seconds. When I first had all my belts done, I had similar symtoms to you and the garage fixed it all for free (as would be expected).
GTV Rob is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

2ts , gtv , noise , squealing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome