Engine Management light & Stalling - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-11-08 Thread Starter
Status: -
AO Member
davidgoodwin180's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Dorset
Posts: 14
Images: 2

Member car:


Engine Management light & Stalling

Hi guys.

Now i should add that there is a very big hole in the exhaust just before the cat.

i have only had my car for about a week now but after picking it up i noticed that every now and then the engine management light would flash up and the car would start running very rough untill i turned the engine off and back on again and all is fine.

But today it started messing around even more, the light flashes on then goes off but the car wont hold the revs up, it just drops off and stalls and when i does decide to run OK it sits at 1000rpm then drops to 500rpm then back up and so on.

I also notice that the engine temp of the car this evening was only sitting past 50 deg, but i wasnt driving hard at all, but think it should still be getting higher.

Thanks and hope somebody can understand what i am trying to say.

davidgoodwin180 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

engine , light , management , stalling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome