Spider throttle problems after timing belt change - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-10-08 Thread Starter
Status: -
Join Date: Jul 2008
Posts: 4

Member car:

Spide 3.0

Not Happy Spider throttle problems after timing belt change

Hi there guys. Just had the timing belt (and spark plugs) changes on my Alfa 3.0 V6 Spider (2002) as it was at the age when it needed it. Had it done by a local Alfa indie as they are really close and price was obviously good!

However, since I got it back, there's a problem with the throttle - when I take my foot off the accelerator the engine continues to rev at around 2000 revs until the car is stationary - this happens whether the car is in gear or not. So when you ease off the accelerator to slow for a junction, the car just keeps going, almost like cruise control!

The Alfa indie has had it back for 2 weeks and still not been able to find the problem - they say they've checked the ABS sensors, the speed sensor in the gearbox, the throttle cable, the communications with the Engine control unit but no joy. HOwever, they also admit they've been really busy so have only spent an hour on it from time to time so not sure how thorough they've been.

Any ideas before I have to take it to the main dealer (Piccadilly in Knaresboro, Yorkshire) and start saving?

alfacyclist is offline  
Sponsored Links
Status: Enjoying the GTV V6
AO Member
freddy's Avatar
Join Date: May 2008
Location: United Kingdom
County: Devon
Posts: 141
Images: 7

Member car:

GTV 3.0 V6 24v

Re: Spider throttle problems after timing belt change

Hi, don't know if you got your issue sorted but I have a 2 ltr spider and experienced lumpy tickover after my belts etc were done. The garage (Autoitaliana - Exeter - brilliant!) had it back and reset the ecu which did the trick. Hope this helps.
freddy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

belt , change , problems , spider , throttle , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome