spider rev hesitation - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-10-08 Thread Starter
Status: -
AO Member
MattyR's Avatar
Join Date: Jun 2006
Location: Perth, Australia
Posts: 26
Hmmm spider rev hesitation

when my spider is running, i go to rev it and it hesitatesfor half a second, sometimes makes a slight pop sound and then revs up. also there is a constant slight lag going up the rev range. ive disconnected the maf and thats not it, was replaced a few months ago, and from looking at a few threads im thinking it could be air filter or timing out? belt was done 5000km ago. the K&N filter doesnt fit totlly properly in the air box, seems tosit ok now but would it be worth going back to stock filter? i just want to get her running perfect as she is up for sale
MattyR is offline  
Sponsored Links
Status: -
AO Member
jonboy64's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Devon
Posts: 41

Member car:

Alfa GTV 3.0 V6

Re: spider rev hesitation

Hi Matty

It could be the throttle sensor - I had the same symptoms on my 3.0 GTV which proved to be a loose connector in the passenger footwell.

If you search for delayed throttle response you will se many threads on this.
Basically the throttle works from a potentiometer & wires run to the throttle body. The offending connector in my case was found in the passenger footwell behind the carpeted section containing the passenger airbag isolator switch. If I remember correctly there are two connectors behind the carpet (held in place by two screws) if you start the engine disconnect the white ? connector then try to rev the engine you will not get any response - hence the correct connector. Have a look at the connecor for any corrosion - clean / spray with contact cleaner (maplins) or wd40 & put back together.
This fixed mine & at £400 for the potentiometer I hope it does yours as well


jonboy64 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

hesitation , rev , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome