Engine cuts out whilst driving? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-10-08 Thread Starter
Status: -
Join Date: Oct 2008
Location: Australia
County: New South Wales
Posts: 7

Member car:

GTV 2.0

Engine cuts out whilst driving?

Does anyone have any specific ideas on what would cause my engine to switch off whilst driving and then not able to restart for a few hours. Basically I think it may be a fuel injection problem but I am not sure. What happens is I will be cruising along and wihout warning the engine will just switch off and then I won't be able to start it again. I'll try and start it a few hours later and sometimes it starts and sometimes it doesn't. Its not the battery as I tested it and all the electrics work. Has anyone experienced this before? I will take it to a mechanic but would like to atleast steer them in the right direction so I don't have to take out a million dollar loan to pay for unecessary repairs.
bullant1977 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,990
Re: Engine cuts out whilst driving?

Usually the TDC Sensor.
When they fail, they fail when hot and don't work again until cooled.
David C is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cuts , driving , engine , whilst

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome