Spider Hood Not Releasing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-10-08 Thread Starter
Status: -
AO Member
J's Avatar
Join Date: Apr 2001
Location: Dublin, Ireland
Posts: 204
Images: 6

Member car:

145 & GT

Spider Hood Not Releasing


I checked this forum but I can't seem to find a definitive answer to the problem I'm having.

The top hadn't been put down on the car since the start of September as I had no access to the car for the last number of weeks.

This weekend I took the Spider out for a spin and tried to put the top down and ran into difficulties, here is the sequence of events.

I set up for dropping the hood, car is running, handbrake is pulled and the clips at the top of the screen released.

I pressed the button on the centre console, the windows dropped.
The motors for releasing the rear hood pins ran but only for a second and then stopped and the LED next to the switch started flashing.

I did get the roof down by using the switch behind the drivers seat to release the rear hood pins and then completed the dropping of the hood using the switch on the centre console.

Putting the roof up everything appeared to work however sometimes the rear hood pins didn't appear to lock completely and the LED next to the switch flashed. I did tighten then down fully using the switch behind the drivers seat and the LED next to the hood switch stopped flashing.

I checked the rear hood pins and the locking mechanism, everything looks ok, I sprayed everything with WD-40 and put fresh LM grease on the pins. The micro switches appear to be working mechanically at least, they are making audible clicks but chances are they are not giving the right information to the hood ecu.

I checked the workshop manual and there is nothing that I can to help diagnose the problem. Can anyone offer any suggestions?

Thanks in advance,

J is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

hood , releasing , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome