Any alternator experts out there? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Any alternator experts out there?

A couple of times this week my charging light has taken 4 or 5 seconds to go out instead of going out instantly. Went to check things out this morning, but all is normal again. I have 12V at the battery which goes straight up to 14V when started (and light goes out instantly). What would cause a charging system to randomly go in and out of lazy teenager mode?

Further clues or red herrings: I have been doing plenty of short journeys recently. Auxiliary belt not squealing. Car starts and runs perfectly. All electrical systems working perfectly except: the car sometimes starts with the climate control on sometimes not. I can hear the compressor click in when I turn on the CC. Aircon would probably benefit from a regas however. I have also heard a very light clicking/tapping for about 20 seconds after start up a couple of times. Sound just like a leaky tappet filling up again so not too concerned (no sound this morning).

Thanks in advance.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

alternator , experts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome