84 2.0L GTV Electronic ignition problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-09-08 Thread Starter
Status: -
Join Date: May 2008
Posts: 3
84 2.0L GTV Electronic ignition problem

The ignition system failed yesterday in my 1984 GTV, I think the cause may be in the control module. Is it possible to update with a newer igntion sytem? Does anyone know what this involves?
ar116 is offline  
Sponsored Links
Status: now I'm not sure
AO Member
whatmoretyres's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Bucks
Posts: 989

Member car:


Re: 84 2.0L GTV Electronic ignition problem


No help I'm afraid, you'll really need to post in the 'classics' section, this section is for 916 GTVs. Drop one of the mods a line and they'll move the post for you
whatmoretyres is offline  
Status: Living la vida loca!
AO Silver Member
v6junky's Avatar
Join Date: Jul 2005
Location: Spain
County: -
Posts: 2,506
Images: 9
Re: 84 2.0L GTV Electronic ignition problem

During the move...

A friend with a GT 1300 had a similar failure and was looking into updating the ignition system. Google a search and you should find a few options out there, or speak to a specialist. You can pretty muck retro fit just about anything these days.
v6junky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

20l , electronic , gtv , ignition , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome