engine keeps cutting out! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-09-08 Thread Starter
Status: -
Join Date: Sep 2008
Location: United Kingdom
County: West Yorkshire
Posts: 1

Member car:

alfa spider

engine keeps cutting out!

can anyone help my spider engine keeps cutting out on me. after leaving it for 10 mins or so it starts again no probs. that is until it does it again. !
fed up driver is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2007
Posts: 96

Member car:

2.4 Spider

Re: engine keeps cutting out!

is it once it gets warm? pretty likely to be crank phase sensor. Well known to kill the engine once warm, quite easy and cheap to replace if i'm not mistaken.... Could be the maf too, i had a new one fitted which was faulty and it meant that as soon as the engine warmed to 75 degrees ish it just straight cut out and wouldnt start again until i cooled.
CCCSSSDDD is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

cutting , engine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome