Immobiliser Problems!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 16-06-08 Thread Starter
Status: -
Join Date: Jun 2008
Posts: 1

Member car:

Alfa Romeo GTV

Immobiliser Problems!!!

Hi There,

I have been driving my Alfa Romeo GTV 2.0 (1997) for a few years now.

I have a question and i was wondering if you would be able to help me??

I forgot to turn off my car stereo and the battery is now flat. I tried to jump start the alfa which i have done in the past and it will usually start first time, however, when i jump start the car and turn the key, the engine will turnover but the immobiliser will not let me fully start the engine. At first the code light stayed on and when i tried again the next day the engine still wont start and the code light is now flashing. I called out the RAC and he couldn't get it started either.

I have 4 keys in total including the master key and it still wont start. I read the manual and it mentioned something about a keycard but i never received one.

I only got a new battery for the Alfa a month ago.

I would be very grateful if anyone has any ideas????

Thank you in advance.
ALFADANO is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Immobiliser Problems!!!

Moved to GTV Tech Lounge
BigFoot is offline  
Status: 17" Speedline Enzo's
Club Member
Membro Premio
Stixy's Avatar
Club Member Number: 479
Join Date: Oct 2007
Location: United Kingdom
County: Norfolk
Posts: 1,281
Images: 14
Re: Immobiliser Problems!!!

Oh dear!!!! Try this it may help if you battery is fully charged then disconnet the Earth wait about 10 mins then reconnect, this sould clear any faults stored. I had this a few month ago, jumped started my car, ran fine to charge battery up, but then it wouldn,t let me start the car again any unless it was jumped again.
Stixy is offline  
Status: NEW ALFA! :D
AO Silver Member
SpiderMJ's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: -
Posts: 1,104
Images: 1
Re: Immobiliser Problems!!!

AFAIK the code cards were not used in some markets. In the UK due to insurance issues I think the cards were never given to drivers, just the key set. All you really need is the master key anyway.. Does anyone here with a UK registered car have a code card??
SpiderMJ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

immobiliser , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome