erratic temp gauge - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 20-05-08 Thread Starter
Status: -
Join Date: May 2007
Posts: 1

Member car:


erratic temp gauge

hi there
new to forum just bought a 96 gtv, seem to have all the normal probs you guys talk about, electrical gremlins! anyone out there had a temp gauge that fluctuates erratically when engine warm? needle bounces between hot and cold very quickly,(5 times per second??) any ideas out there?
ian crow is offline  
Sponsored Links
Status: -
AO Silver Member
156_TSpark_Boy's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Greater London
Posts: 1,263
Re: erratic temp gauge

Welcome to enjoy your stay
156_TSpark_Boy is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,050
Images: 2
Re: erratic temp gauge

Hi Ian give our tech sections a look through for more info and help. cheers.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: erratic temp gauge

Moved to GTV Lounge
BigFoot is offline  
Status: NEW ALFA! :D
AO Silver Member
SpiderMJ's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: -
Posts: 1,104
Images: 1
Re: erratic temp gauge

Possible airlock by the sounds of it. Try squeezing the hoses which circulate the coolant. If you get bubbles coming up and out of your resevoir then thats likely the cause.

edit: ah sorry probably not if it's 5 times per second! sounds like it might be an electrical fault of some type or dodgy gauge then.. Checked the connection to the thermostat housing?
SpiderMJ is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Re: erratic temp gauge

Does it still flutuate wildly while the car is standing or does it do it only when the car is moving ?

If it fluctuates only when the car is moving a loose connection somewhere sounds probable, if it does it all the time could be a faulty gauge or sender. These are only suggestions, haven't come across this before.

Good Luck.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

erratic , gauge , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome