New battery and now she won't idle?!? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-05-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2007
Posts: 12

Member car:


Help New battery and now she won't idle?!?

1996 GTV 2l TS. Poor girl was left standing and battery died and wouldn't take a charge. She's start fine but won't idle at start up and every time I stop the idle is a lottery! Will she stall out or won't she?

Also radio power now turning on and off constantly?!?

Spud is offline  
Sponsored Links
Status: NEW ALFA! :D
AO Silver Member
SpiderMJ's Avatar
Join Date: Mar 2008
Location: United Kingdom
County: -
Posts: 1,104
Images: 1
Re: New battery and now she won't idle?!?

Checked the connections to the battery? Sounds like possible loose connection or a short somewhere, although with the later you would expect a fuse to blow.
SpiderMJ is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Re: New battery and now she won't idle?!?

Yep, always check in the area that's just been worked on, I don't believe in coincidences. Get the torch out and have a real good look at and around the battery.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

battery , idle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome