'sad looking alfa' - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-03-08 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Location: United Kingdom
County: Scottish Borders
Posts: 55

Member car:

2.0l TS GTV

'sad looking alfa'

I posted about this car a while ago. I'm going to look at it properly tomorrow. It hasn't run for about two years!!!!. Does that mean the variators while be dry and sustain huge amounts of wear at start up until the 'get wet' ? Should i bank on replacing them, the cambelt was done just before it was laid up but i dont think the variators were!
Any thoughts?
trampintransit is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Cardiff
Posts: 683
Re: 'sad looking alfa'

Take a fresh battery with you or some jump leads. Remove the plug for the coil packs and the fuse for the fuel pump and crank it over a bit to build up some oil pressure before you start it.
Escy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome