Radio reception problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-03-08 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 3
Radio reception problem

Hello chaps..any suggestions please. I am new member with a 2003 GTV Lusso. Very few problems other than radio. Bought car from new..fitted with sony removal face plate radio / CD. Over past year the radio does not receive excellent reception, as before. Took it to local radio fitter who stated that he had fitted new tuner..very doubtfull as the problem was not rectifed but he made no charge. Then was informed that the problem might be aerial related so I had a new front to rear cable fitted 75..but problem not fixed. Even thought of buying new sterio but I am so pleased with the CD on the Sony..was reluctant to fork out any more dosh. Any suggestion please..the aerial is electric.
angusbtp@tiscal is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2007
Posts: 185

Member car:

GTV 2.0 Lusso

Re: Radio reception problem

I had this problem and like you thought it might be the radio. It turned out to the be the airel cable that runs from front to back. From the way that it runs though the car its quite easy for it to be broken and thus cause a bad reception. The previous garage had just shoved a bigger piece of wire though the outer cable in an attempt to pick up a signal.

You may want to check the grounding on the airel itself and that the connections are good. Also are you sure that they acutally replaced the lead?
CooK1E is online now  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,082
Images: 22
Re: Radio reception problem

As a quick check you could buy a cheap aerial and plug it directly into the radio. If this works fine you probably have a bad cable. If it still doesn't work well you have a radio problem. Whilst doing this check do ensure that both the temporary aerial and radio are grounded correctly.
Nige005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

problem , radio , reception

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome