gtv wiper issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-10-16 Thread Starter
Status: -
Newbie
 
capristeve's Avatar
 
Join Date: May 2016
County: Dorset
Posts: 9
Garage
gtv wiper issues

before i start pulling things apart this weekend i just wanted to get peoples thoughts, tonight i removed the wiper arms and scuttle panels, ran the wiper motor on all speeds and intermittent and whilst running they seem to cycle as they should...
BUT! when i turn them off (regardless of speed setting) they do their final cycle, and on the down stroke the wiper position stops half way down the screen, (not just above the park position) literally at 45 degrees across the screen,
my thoughts are, removing the wiper motor assembly and cleaning it, discuss?
capristeve is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Oct 2012
Location: United Kingdom
County: Surrey
Posts: 536
Before you go through all that hassle have you tried swapping the relay? had erratic wipers on my old merc when I got it and that fixed it.
sraouf is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
gtv , issues , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome