Help - engine loom plug issue! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-10-16 Thread Starter
Status: -
Newbie
 
Join Date: Jan 2015
Location: United Kingdom
County: Wiltshire
Posts: 8

Member car:

Alfa GTV 2.0 TS

Help - engine loom plug issue!

Hi there,
I have X reg 2.0 GTV that suffered a minor engine fire. Luckily most of the damage was limited to plastic replaceable trim in the engine. The big problem is that the engine wiring loom into the ECU has melted. A friend who is an ex Alfa mechanic has been helping me out but we are having real issues finding a loom with the smaller ECU lead plug heads which we intend to 'graft' onto the old loom (to save having to strip the whole lot out).

I also have a 'donor' GTV that a friend gave me but has the later Motronic 7.3.1. I have a motronic M1.5.5


So, I am looking for help in either solving the problem on:

- does anyone have the loom cable connector plugs or an old loom for a motronic M1.5.5 that we can use to raft onto my existing loom (once we have cut the wires back to the undamaged part.

I really don't want to get rid of the car as the rest of it is in excellent condition - only 80K, new clutch, new brakes etc.

All help gratefully appreciated

Didi
Attached Images
File Type: jpg motronic M1.5.5.jpg (8.3 KB, 4 views)

Last edited by didithevan; 17-10-16 at 15:56. Reason: Updated information
didithevan is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Nov 2011
Location: United Kingdom
County: Bristol
Posts: 1,408
Images: 2
Have you got a photo of the plug you need. I have a mass of connectors that you are welcome to. Came off an S reg TS.
spankdanny is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
engine , issue , loom , plug

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome