gtv tapping - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 16-01-08 Thread Starter
Status: -
Join Date: Feb 2007
Posts: 6
gtv tapping

hi there i have just spent all day fitting a new cam belt and vairiator to my gtv and all is ok turned over by hand all marks lined up used the cam locks but i have now got a ticking noise coming from the engine it sounds like a sticking tappet not very loud but a new noise none the less does the variator need time to fill with oil ? i only ran it for a few mins then stopped it as i had stuff to do i dont just want to thrash it and see if it goes has any one else had this problem?
jodydid is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Cardiff
Posts: 683
Re: gtv tapping

I had this last night. Takes time for it to go away. Took mine about 3-4 mins on idle. It's silent now.
Escy is offline  
Status: Wants a 147! :)
AO Silver Member
stu_the_flat's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Glasgow
Posts: 3,436
Images: 4
Re: gtv tapping

I've had the same problem in my 166 V6. Its being fixed today so I'll tell you what the fault was if that helps you.

If found that the noise diminished once the engine had been warmed up.
stu_the_flat is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

gtv , tapping

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome