Clutch pedal travel changed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1Likes
  • 1 Post By spankdanny
 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 22-09-16 Thread Starter
Status: -
AO Member
 
Chris141058's Avatar
 
Join Date: Mar 2006
Clutch pedal travel changed

Hi
The way my clutch pedal depresses has suddenly changed on my GTV V6.
It now goes a third of the way down with very little resistance before working in the normal way. It still changes gear ok but I am worried that if this gets worse there will not be enough travel to engage/disengage the clutch.
I am currently on holiday in Wales where I was hoping to do some spirited mountain driving but this is on hold!
Any suggestions for the cause or solution would be appreciated.
Thanks
Chris
Chris141058 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
Join Date: Nov 2011
Location: United Kingdom
County: Bristol
Images: 2
Most likely culprit and first place to look is the slave cylinder on top of the gearbox. Peel back the rubber cover and look for moisture.
ron.dullage likes this.
spankdanny is offline  
Status: -
AO Member
 
Join Date: Sep 2013
Location: Australia
County: Victoria
Quote:
Originally Posted by spankdanny View Post
Most likely culprit and first place to look is the slave cylinder on top of the gearbox. Peel back the rubber cover and look for moisture.
I regularly get that problem on my spider twinny. It occurs when the mats move around and block the clutch travel (I don't use the clips for the mats). Try this first.

Robert
roblatt is offline  
Status: now a diesel head..
AO Silver Member
 
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Slave or master cylinder almost certainly.

Just had exactly the same thing on the GT.
joeymannero is offline  
(Post Link) post #5 of 6 Old 23-09-16 Thread Starter
Status: -
AO Member
 
Chris141058's Avatar
 
Join Date: Mar 2006
Thanks guys.
After 3 days with the problem it has cured itself. I know this will only be temporary so I will check the slave and master calendars when I get back from my hols.
Chris
Chris141058 is offline  
Status: Still So Far To Go!
AO Member
 
ron.dullage's Avatar
 
Join Date: Aug 2013
Location: United Kingdom
County: Kent
Quote:
Originally Posted by spankdanny View Post
Most likely culprit and first place to look is the slave cylinder on top of the gearbox. Peel back the rubber cover and look for moisture.
I agree that it could well be the slave but it could also be the master cylinder.
ron.dullage is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
changed , clutch , pedal , travel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome