Who's tried to start a P2 GTV T-Spark after 8 years ??!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 6 Old 08-09-16 Thread Starter
Status: -
AO Member
 
Join Date: Dec 2014
Location: United Kingdom
County: West Yorkshire
Posts: 68
Who's tried to start a P2 GTV T-Spark after 8 years ??!!

OK so I figured something might not go quite to plan at the outset, but.......

New fuel pump, it primes, if I pull the pipe off the engine rail it fills a jam jar nice and quickly....

Oil and filter change, spark plug clean, I turned the engine over upto oil pressure was reached before hand a few times with the plugs out and no fuel pump.

So it caught 3 times, ran upto 1500 rpm and died. I tried it maybe another 20 times, it nearly catches but doesn't.

So, I figure I am getting a spark and there is fuel. I am wondering if the injectors, throttle or MAF are fubar'd, I've no idea. All the dash lights behave as they should it seems....

Please could somebody talk me through a mug's guide? Do I need to get an adapter for my computer and start reading fault codes or something?

I would be grateful for any help. Now I see why my old TR6 was so much easier!
GTVblackandred is offline  
Sponsored Links
Advertisement
 
Status: Inspired
AO Gold Member
 
Verbout's Avatar
 
Join Date: Feb 2014
Location: United Kingdom
County: West Yorkshire
Posts: 9,959
Images: 11
Garage
Are you using fresh fuel?

I don't think your issue can be diagnosed that easy, all advice would be to work your way through a checklist, checking for spark, injectors firing etc, its a logical checklist you'll have to adopt.

That is unless there is a magical reason for the non start that only P2 GTV T-Spark owners know.
Verbout is offline  
Status: profesional ledgend
AO Silver Member
 
bradpit999's Avatar
 
Join Date: Oct 2010
Location: United Kingdom
County: West Midlands
Posts: 2,395
Images: 42
Garage
fresh fuel is a must .......... 8 year old fuel is 30 octane
bradpit999 is offline  
 
pkr
Status: Planning the next project ...
AO Silver Member
 
Join Date: May 2007
Location: United Kingdom
County: Bedfordshire
Posts: 4,030
Will it idle indefinitely when you start it and only stalls when increased to 1500 RPM? Fuel starvation?

As the car has had a replacement pump, that would be my prime suspect. Just because it'll fill a jar, doesn't mean it's delivering the correct pressure needed.
pkr is offline  
Status: now a diesel head..
AO Silver Member
 
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,818
syphon tank and put in fresh fuel before anythig else...

if no joy then clean ICV,throttle body and maf, check for air leaks...had a similar thing recently and it all cleared up with a fresh battery..
joeymannero is offline  
(Post Link) post #6 of 6 Old 08-09-16 Thread Starter
Status: -
AO Member
 
Join Date: Dec 2014
Location: United Kingdom
County: West Yorkshire
Posts: 68
Well PKR I'd been fearing the pump might not be maintaining pressure as I have just rebuilt it (see my other thread) but I would be surprised. Yes, it gets to 1500 rpm and then dies. But it has only managed that 3 times.

Checking the injector spraying into a jar may be a good idea....... I cleaned the tank out when I had the pump out, and filled in with 2 gallons of fresh 95 Unleaded.
GTVblackandred is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
gtv , start , tspark , years

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome