Thermostat - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-09-16 Thread Starter
Status: just wondering
AO Member
The Rat's Avatar
Join Date: Sep 2005
Location: Sudbury Suffolk
Posts: 346
Images: 6

I was having issues with the thermostat on my 99 twin spark Spider to the point I bought a new thermostat. I took the car to hampshire at the weekend and now the thermostat appears to be working perfectly. Instead of dropping below 90 and going tepid the temperature gauge remains at 90 and the heat can be controlled now. Bizarre or just an Alfa???
The Rat is offline  
Sponsored Links
Status: -
AO Member
Nellytheroc's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Norfolk
Posts: 246
Probably both. I thought my temp gauge had gone as the needle never moved but on advice from this site I got the thermostat changed and hey presto the gauge worked for a couple of weeks and stopped working again. Apparently thermostats go on a regular basis on Alfas. Don't know if mine has gone again or it's something else.
Nellytheroc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome