Spider v6 low fuel pressure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 31-08-16 Thread Starter
Status: -
AO Member
Join Date: Oct 2014
Location: Andover
County: Hampshire
Posts: 35

Member car:

alfa 156 jtd 20v

Spider v6 low fuel pressure

Hi all. Been zipping around in the v6 with the top down and loving it.
BUT. It doesn't always start straight away in fact rarely and only when cold struggles when warm. It turns over fast and new plugs etc so I guessed crank sensor and fitted new bosch one to no avail.
Thought it might be maf but upon checking codes ( which I do regularly at the moment) I have had code p0087 low fuel rail pressure on a couple of occasions. This could explain the slow starting with the wif of petrol but there is no loss of power under load and i can here the pump working when turned to mar? So as usual any advise/experience would be gratefully received.
I'm going to clean the maf anyway
timw1114 is offline  
Sponsored Links
Status: -
AO Silver Member
SLM3CFC's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Greater London
Posts: 2,363
Leaking injectors. Leak from connections to fuel rail.

Sent from my SM-G935F using Tapatalk
SLM3CFC is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

fuel , low , pressure , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome