dodgy temp sender causing high idle?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 31-12-07 Thread Starter
Status: -
AO Member
llahwerdna's Avatar
Join Date: Oct 2007
Location: gloucester
Posts: 155

Member car:

gtv 3.0 v6

dodgy temp sender causing high idle??

Hi, I have been looking through various items on here with regards to the temperature the car gets to and over fuelling causing poor performance. Now I have have changed a lot of parts recently inc thermostat, maf, plugs, oxygen sensor and cleaned the throttle body and it just occured to me that i changed the thermostat quite early on which was when the high ideling started. I previously had no ideling problems but just terrible stuttering caused by the maf so i changed that and the thermost had gone so i changed that at more or less the same time. The temp on my car reads at about 75 to 80 except in traffic where it rises but the idle is always at 1500 no matter the conditions. could the car be getting more fuel than needed because of the temp not reaching 90 therefore causing high idle. its very confusing. could it be the temp sender unit? if so why did it idle ok before with a dodgy thermostat....hmmm i seem to be going round in circles here
llahwerdna is offline  
Sponsored Links
Status: -
AO Silver Member
DevonDan's Avatar
Join Date: May 2007
Location: Exeter
Posts: 1,532
Re: dodgy temp sender causing high idle??

Sounds like the stat is working fine, thats exactly what it should do.

DevonDan is offline  
Status: Alfa-less and lost.
AO Silver Member
fantom alfa's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Warwickshire
Posts: 1,108
Images: 6

Member car:

'01 GTV 3.0V6

Re: dodgy temp sender causing high idle??

Sounds like your cooling system is working as it should be, but yes in principle if your ECU was being told that the temp was too low the ECU would inject more fuel and idle faster. Maybe the ECU learning procedure will help. Also check your air intake has no leaks.
fantom alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

causing , dodgy , high , idle , sender , temp

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome