airbag light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
  Home Forums AO Club Member Gallery Classifieds Trade Directory  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Reply
 
LinkBack Thread Tools
  #1 (Post Link)  
Old 31-05-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

airbag light

hi all ' need a bit of hellp' can some one tell me what i need to get for reseting airbag light thanks
Reply With Quote
Sponsored Links
Advertisement
 
  #2 (Post Link)  
Old 31-05-13
GTV_Blue's Avatar
Status: Suspension re-build complete, what next?
Club Member
Membro Premio
 
Club Member Number: 1710
Join Date: Oct 2012
Location: United Kingdom
County: Leicestershire
Posts: 871
Images: 9

Member car:

GTV 3.0 V6 24v

Have you done a search? There are loads of threads about this!

You'll need a KKL lead, either one with colour coded adaptors to switch the pins, or the switchable type like this http://www.ebay.co.uk/itm/vag-kkl-40...#ht_1706wt_847 (this is the one I have). Download the latest FTDI Virtual COM port (VCP) drivers and the free copies of MultiECUScan & DnECUDiag*(was AlfaDiag). You'll need to run the software as an administrator (different proceedures depending on Windows Version, do a search) and turn off all firewalls, so make sure you turn your WiFi connection off to stop attacks while doing this. If you are lucky the software will work first time, if not it will take some tinkering and cursing.

BTW You need to remove the seatbelt pre-tensioner connector and replace it with a choc block or a new connector to stop the light coming on again; especially if like me you take kids in the back who stick they're feet under your seat.


"When I see an Alfa Romeo I lift my hat" - Henry Ford
Reply With Quote
  #3 (Post Link)  
Old 31-05-13
Tommywho156's Avatar
Status: Glad to be back in an Alfa :)
AO Silver Member
 
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 1,904

Member car:

GT Blackline JTDm

I created the following thread for 147, 156 and GT owners but may be applicable for other models. It covers the main cause and how to fix and also gives details of cables and software required to sort the most common cause of this fault.. http://www.alfaowner.com/Forum/alfa-147-156-and-gt/377491-how-to-fix-your-airbag-light.html#post5311352
Reply With Quote
  #4 (Post Link)  
Old 31-05-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

hi chaps and thanks for posts 'not had a lot of luck with research as dont know what am looking for ( till now) 'as thay say ask the man that can 'all going well with the light reset will get mot and hit the road for the first time in 2years 'happy days
Reply With Quote
  #5 (Post Link)  
Old 31-05-13
GT Paddy's Avatar
Status: Long live the nice weather
AO Member
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 943

Member car:

Audi A3 & Alfa Spider V6

You need this lead. Other recent posts have shown people having massive problems with leads they have bought basically not working. This one has always worked for me and others.

http://www.ebay.co.uk/itm/ALFA-FIAT-...item3a810b7f4d
Reply With Quote
  #6 (Post Link)  
Old 31-05-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

thanks paddy' have now sent order' will post update and let you's know how it works out 'or post for more hellp if i cant work it out' lol ' cheers mate have a alfa wave from me
Reply With Quote
  #7 (Post Link)  
Old 31-05-13
GT Paddy's Avatar
Status: Long live the nice weather
AO Member
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 943

Member car:

Audi A3 & Alfa Spider V6

Let me know if you need any help when it arrives.
Reply With Quote
  #8 (Post Link)  
Old 31-05-13
ku$t's Avatar
Status: fixing up GTV #2
AO Member
 
Join Date: Apr 2008
Location: United Kingdom
County: North Yorkshire
Posts: 191

Member car:

P1 GTV 2.0TS + Mitsi L400

Apologies for hijacking the thread, but does the airbag warning light come on (and go off again) at ignition? Like the ABS, engine ECU, seatbelt light etc?
Reply With Quote
  #9 (Post Link)  
Old 31-05-13
GT Paddy's Avatar
Status: Long live the nice weather
AO Member
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 943

Member car:

Audi A3 & Alfa Spider V6

Yes it does. However if it senses a fault, normally caused by the cable being stretched by the seat moving, the light stays on permanently until it is reset. I see you have a phase 1 GTV which this cable will not fix as the diagnostic port is different. There are links on here to fix this but it is a little more complicated for the phase 1 owners.
Reply With Quote
  #10 (Post Link)  
Old 31-05-13
ku$t's Avatar
Status: fixing up GTV #2
AO Member
 
Join Date: Apr 2008
Location: United Kingdom
County: North Yorkshire
Posts: 191

Member car:

P1 GTV 2.0TS + Mitsi L400

Thanks Paddy, I feel a temporary fix coming on as I already have my instrument cluster opened up. I'll order my OBD 2 lead (with the 3 pin adaptor lead for my P1) ASAP...wish I had the Becker airbag ECU!
Reply With Quote
  #11 (Post Link)  
Old 05-06-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

hellp

Originally Posted by GT Paddy View Post
Let me know if you need any help when it arrives.
hi paddy got the cable but cant get the drivers to load
Reply With Quote
  #12 (Post Link)  
Old 05-06-13
GT Paddy's Avatar
Status: Long live the nice weather
AO Member
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 943

Member car:

Audi A3 & Alfa Spider V6

What error are you getting?
Reply With Quote
  #13 (Post Link)  
Old 05-06-13
Status: -
AO Member
 
Join Date: Oct 2012
Location: Portugal
County: -
Posts: 44

Member car:

Alfa 147 1.6

hello i need some help! i had before the driver airbag light on because i remove the seats for clean, and forget the light issue! but after this i go in shop and they connect to computer and remove the light for pass inspection

But now i have 2 lights on! the driver and passenger, and i don't make nothing wrong! i assume maby some shock in road activate the error!

my problem now is i like to solve this!

some guys tell for remove the seat connectors and put a resistor on it for fooling the ECU! so made this the airbags always is on correct?(ecu assume always people on seat and in accident set of airbag) and if a make this the light disappears? or need to go in examiner same way?

please somebody tell the resistor capacity? 2ohms or 2.3 for 147? thank you

Last edited by Rcgomes; 05-06-13 at 17:56.
Reply With Quote
  #14 (Post Link)  
Old 05-06-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

Hi paddy ' think the computer has issues with the software'have followed the information on the card 'but nothing works 'going into pc world on friday will see if thay can load it when am in ' thanks for your hellp
Reply With Quote
  #15 (Post Link)  
Old 06-06-13
Rod Duggan's Avatar
Status: -
AO Member
 
Join Date: Jan 2008
Location: Surrey
Posts: 173
Images: 4

Member car:

Spider 2000

Cleaning the connectors several times didn't work for me, they had worn/expanded out of spec. Replacing them with these: (thread 267071-fixing-those-underseat-connectors) has now fixed it permanently with no need for any diagnostic/resetting exercises. Drivers seat is moved every few days when the wife & I take turns in driving it.
Reply With Quote
  #16 (Post Link)  
Old 08-06-13
Status: mellow yellow
AO Member
 
Join Date: Jan 2010
Location: Spain
County: Santa Cruz de Tenerife
Posts: 132
Images: 6

Member car:

1998 spyder 1.8twin spark

had my light turned out,tensioner replaced, three days later it came on again going round a roundabout..... whats all that about..back to the black tape..
Reply With Quote
  #17 (Post Link)  
Old 09-06-13
Rod Duggan's Avatar
Status: -
AO Member
 
Join Date: Jan 2008
Location: Surrey
Posts: 173
Images: 4

Member car:

Spider 2000

Its all about ... the underseat connectors.
Reply With Quote
  #18 (Post Link)  
Old 09-06-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

Hi paddy 'just got pc back and the drivers are in 'but still no joy when i put it in on pin3 just came up with can't coneck to ecu 'and to check the cable but?

all looks ok
Reply With Quote
  #19 (Post Link)  
Old 10-06-13
Status: mellow yellow
AO Member
 
Join Date: Jan 2010
Location: Spain
County: Santa Cruz de Tenerife
Posts: 132
Images: 6

Member car:

1998 spyder 1.8twin spark

Like...
Reply With Quote
  #20 (Post Link)  
Old 14-06-13
patnagreen's Avatar
Status: -
AO Member
 
Join Date: Jun 2012
Location: United Kingdom
County: South Ayrshire
Posts: 39
Images: 6

Member car:

1999 SPIDER and 147 gtd

hi paddy the light is now out 'the problem was a bad earth wire ' thanks for all your help its very good of you to take the time and help 'the forum works ' cheers mate
Reply With Quote
  #21 (Post Link)  
Old 15-06-13
GT Paddy's Avatar
Status: Long live the nice weather
AO Member
 
Join Date: May 2008
Location: United Kingdom
County: Hampshire
Posts: 943

Member car:

Audi A3 & Alfa Spider V6

Originally Posted by patnagreen View Post
hi paddy the light is now out 'the problem was a bad earth wire ' thanks for all your help its very good of you to take the time and help 'the forum works ' cheers mate
Not a problem. It is satisfying when you finally turn that light out!
Reply With Quote
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa GTV & 916 Spider

Tags
airbag, light

Thread Tools


Recently 'Read'
No History to show

Useful Links
Lost Password?
AO Merchandise
FAQs
Register

External Links
2005 Alfa 156 2.4...
Alfa-CF2-V6-Plenum-C...
Alfa-CF3-V6-Plenum-C...
Kleber Quadraxer...
Alfa Romeo 156...

Alfa Romeo

Recent Image

My Latest Transport

View Verbout's images

Search

Forums

Classifieds
   

Gallery

Social Groups
   

Members
   


Did you know..?
Did you know..?
You can change the look and feel of AO by changing your colour scheme

   

New To Site? Need Help?

All times are GMT. The time now is 04:55.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560 561 562 563 564 565 566 567 568 569 570 571 572 573 574 575 576 577 578 579 580 581 582 583 584 585 586 587 588 589 590 591 592 593 594 595 596 597 598 599 600 601 602 603 604 605 606 607 608 609 610 611 612 613 614 615 616 617 618 619 620 621 622 623 624 625 626 627 628 629 630 631 632 633 634 635 636 637 638 639 640 641 642 643 644 645 646 647 648 649 650 651 652 653 654 655 656 657 658 659 660 661 662 663 664 665 666 667 668 669 670 671 672 673 674 675 676 677 678 679 680 681 682 683 684 685 686 687 688 689 690 691 692 693 694 695 696 697 698 699 700 701 702 703 704 705 706 707 708 709 710 711 712 713 714 715 716 717 718 719 720 721 722 723 724 725 726 727 728 729 730 731 732 733 734 735 736 737 738 739 740 741 742 743 744 745 746 747 748 749 750 751 752 753 754 755 756 757 758 759 760 761 762