uConnect 6,5" Firmware Update - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 2Likes
Reply
 
Thread Tools
(Post Link) post #1 of 29 Old 4 Days Ago Thread Starter
Status: brujer@gmail.com
AO Member
 
Join Date: Aug 2016
County: Germany
Posts: 27
Idea uConnect 6,5" Firmware Update

Hello,

I found on a italian alfa forum the ltest firmware update for the uConnect 6,5". It is compatible with both the Live and the NON-Live models.
Just download the zip and extract it on a freshly formatted (FAT32) 4Gb or bigger USB stick. After that just stick it in the USB port and wait a minute or so. You should get a prompt to install the update.
As a precaution, make a hard reset(factory reset) of the unit before upgrading.
Here is the LINK for the update and the LINK of the original thread.
mru likes this.

Last edited by Metallus; 4 Days Ago at 06:47. Reason: Cleanup
Metallus is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 29 Old 4 Days Ago
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Does this update cover all languages and what's new in this update?
Troogroove is offline  
(Post Link) post #3 of 29 Old 4 Days Ago
Status: trying to stay awake at work!
AO Member
 
raul's Avatar
 
Join Date: Aug 2008
Location: RUISLIP LONDON
Posts: 677
Images: 5

Member car:

Guilietta qv

What new about the update?

Sent from my HTC 10 using Tapatalk
raul is offline  
 
(Post Link) post #4 of 29 Old 4 Days Ago Thread Starter
Status: brujer@gmail.com
AO Member
 
Join Date: Aug 2016
County: Germany
Posts: 27
Quote:
Originally Posted by Troogroove View Post
Does this update cover all languages and what's new in this update?
I think so. I updated mine which is an import from Denmark. I live in Germany, but have it set on English because of personal reasons.
As to what's new, there are a few modifications to the overall interface. To name a few, on the "MORE" page there are a few more info's about the fuel consumption, Trip A and Trip B. It also is a bit snappier overall. I just reported what the others on the italian forum have posted. I am not an Italian native or cannot speak Italian, but my native language allows me to understand it pretty well. I don't have a changelog or anything.
Just wanted to report it here too, as it seems it's a pretty big update.
And if your unit is NOT a live one, it will remain so after the update. It CANNOT activate LIVE options/services on a NON-Live unit.
Metallus is offline  
(Post Link) post #5 of 29 Old 4 Days Ago
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Thanks for the info I will update mine tonight. Now all I want is the apple CarPlay to be available
Troogroove is offline  
(Post Link) post #6 of 29 Old 3 Days Ago
Status: -
AO Member
 
Kidz147's Avatar
 
Join Date: Dec 2015
Location: Gloucestershire
County: UK
Posts: 47

Member car:

Giulietta QV

Quote:
Originally Posted by Troogroove View Post
Thanks for the info I will update mine tonight. Now all I want is the apple CarPlay to be available
I'd be interested as to how you get on Troogrove. Also what is the sound and any performance gains like from your wizard back box?

Cheers
Andy
Kidz147 is offline  
(Post Link) post #7 of 29 Old 3 Days Ago
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Quote:
Originally Posted by Kidz147 View Post
I'd be interested as to how you get on Troogrove. Also what is the sound and any performance gains like from your wizard back box?

Cheers
Andy
I have just finished the update and here are the results:

1. The update on my uConnect Live on my 2016 G took 22 minutes
2. Once the system has rebooted and started up I had to perform a reset to defaults as there was no sound coming out of the speakers. I do have the Bose audio installed but I dont think that was the problem
3. After the reboot everything was fine and I had sound out the speakers, one thing to note the volume level after the reset is at 0
4. The whole system works so much faster now, when I used to press on a on screen button or option there was a pause before anything happened. Now its press and its there
5. Playing music from a USB drive is alot quicker, when you press browse there is no loading screen any more the list is just there and scrolling through the list is lightening fast
6. Under the apps menu there are some new items and the connection to the app on the phone is instant no more waiting for the Live button to activate

Overall a much needed update to the system all that is needed now is the addition of Apple CarPlay to the system and everything will be complete.

This is the method I used:

a. Turn on the ignition and radio
b. Put USB drive in the USB slot
c. Wait for the system to read the drive and then it displays a message that there is an update available, it tells you the new version on the USB drive and the current Version on the system. Mine was Version 16.45
d. Click the button to install then sit back and wait, there are 9 parts to the update process the first 4 take the longest time with the remaining ones shooting along
e. Once the update has finished it will stick on screen showing 100% and 100% just leave it be and the system will reboot. Once it has rebooted leave it for a couple more minutes
f. Go into the settings menu and reset the system back to defaults. This wont delete your saved radio stations but will turn on all the default options like the beep sound when you press a button
g. Give the system another couple of minutes and it will reboot again
h. Enjoy the new faster system
BrighouseAlfa likes this.
Troogroove is offline  
(Post Link) post #8 of 29 Old 3 Days Ago Thread Starter
Status: brujer@gmail.com
AO Member
 
Join Date: Aug 2016
County: Germany
Posts: 27
Quote:
Originally Posted by Troogroove View Post
I have just finished the update and here are the results:

1. The update on my uConnect Live on my 2016 G took 22 minutes
2. Once the system has rebooted and started up I had to perform a reset to defaults as there was no sound coming out of the speakers. I do have the Bose audio installed but I dont think that was the problem
3. After the reboot everything was fine and I had sound out the speakers, one thing to note the volume level after the reset is at 0
4. The whole system works so much faster now, when I used to press on a on screen button or option there was a pause before anything happened. Now its press and its there
5. Playing music from a USB drive is alot quicker, when you press browse there is no loading screen any more the list is just there and scrolling through the list is lightening fast
6. Under the apps menu there are some new items and the connection to the app on the phone is instant no more waiting for the Live button to activate

Overall a much needed update to the system all that is needed now is the addition of Apple CarPlay to the system and everything will be complete.

This is the method I used:

a. Turn on the ignition and radio
b. Put USB drive in the USB slot
c. Wait for the system to read the drive and then it displays a message that there is an update available, it tells you the new version on the USB drive and the current Version on the system. Mine was Version 16.45
d. Click the button to install then sit back and wait, there are 9 parts to the update process the first 4 take the longest time with the remaining ones shooting along
e. Once the update has finished it will stick on screen showing 100% and 100% just leave it be and the system will reboot. Once it has rebooted leave it for a couple more minutes
f. Go into the settings menu and reset the system back to defaults. This wont delete your saved radio stations but will turn on all the default options like the beep sound when you press a button
g. Give the system another couple of minutes and it will reboot again
h. Enjoy the new faster system
The BOSE sound problem after the update is also known, but it seems as non-existent as after the reset to defaults it works again.
On another note, I thought that apple carplay was already available to the LIVE versions.
Metallus is offline  
(Post Link) post #9 of 29 Old 3 Days Ago
Status: -
AO Member
 
ricardo75's Avatar
 
Join Date: Aug 2011
Location: United Kingdom
County: Surrey
Posts: 94
Does the update change the Alfa logo on startup?
ricardo75 is offline  
Status: -
AO Member
 
alfaquo's Avatar
 
Join Date: Feb 2015
Location: Belgium
Posts: 28
Quote:
Originally Posted by Metallus View Post
I think so. I updated mine which is an import from Denmark. I live in Germany, but have it set on English because of personal reasons.
As to what's new, there are a few modifications to the overall interface. To name a few, on the "MORE" page there are a few more info's about the fuel consumption, Trip A and Trip B. It also is a bit snappier overall. I just reported what the others on the italian forum have posted. I am not an Italian native or cannot speak Italian, but my native language allows me to understand it pretty well. I don't have a changelog or anything.
Just wanted to report it here too, as it seems it's a pretty big update.
And if your unit is NOT a live one, it will remain so after the update. It CANNOT activate LIVE options/services on a NON-Live unit.
What are the adjustments if you performed the update in the uConnect Navi (6.5 ") of 05-2015 ?
alfaquo is offline  
Status: Alfa and Omega
AO Member
 
Join Date: May 2007
Location: United Kingdom
County: Flintshire
Posts: 111
Thanks for this, I have applied the update on my UConnect (Non-Live), I haven't had the chance to test the update properly, but now I have a hissing noise coming out of the speakers, I have the Bose system.
Does anyone know how to fix this issue? I have done a reset as there was no audio initially.
alfista68 is offline  
Status: -
AO Member
 
slaterk's Avatar
 
Join Date: Jul 2003
Location: United Kingdom
County: Hertfordshire
Posts: 194
Doing mine as we speak.
slaterk is offline  
Status: -
AO Member
 
slaterk's Avatar
 
Join Date: Jul 2003
Location: United Kingdom
County: Hertfordshire
Posts: 194
All done. No problems. Did get the hissing (I have Bose too) but it disappeared after the second reset.
slaterk is offline  
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Just an update for some, since I did the update on a uConnect Live system which is working alot better I had a message come up on screen that there was an update for the Live apps part. The update is only about 5MB and downloads using your phone, i am not sure what it has done yet but if i find out I will let people know.
Troogroove is offline  
Status: -
AO Member
 
Join Date: Jan 2005
Posts: 37
Just done my non-live 16 QVL with no problems ( I left engine running as I didn't want it to turn off after 20 mins ! ) , as above system is faster with some extras under the more button and other things have changed in some of the menu's . One thing to note is once its connected to my iPhone it now comes up with Siri under the signal strength in phone settings so not sure if / how Siri can now be activated with car system ?
andyvee is offline  
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Quote:
Originally Posted by andyvee View Post
Just done my non-live 16 QVL with no problems ( I left engine running as I didn't want it to turn off after 20 mins ! ) , as above system is faster with some extras under the more button and other things have changed in some of the menu's . One thing to note is once its connected to my iPhone it now comes up with Siri under the signal strength in phone settings so not sure if / how Siri can now be activated with car system ?
If you hold the voice button on the steering wheel Siri comes up on the display and you can use it from there. Carplay is still not part of this update yet as you cannot pair the system with a phone, the phone doesn't detect the system when you try and pair it.
Troogroove is offline  
Status: -
AO Member
 
Join Date: Jan 2005
Posts: 37
Thanks , that works a treat

Not sure how this update was found but any chance there is one for the 5" ( no nav ) as fitted in 15 plate Mito's , be nice if the wife had access to Siri as well ?
andyvee is offline  
Status: -
AO Member
 
silverevo's Avatar
 
Join Date: Jul 2010
Location: United Kingdom
County: Kent
Posts: 157
Is this a genuine update? The only reason I ask is if you open the file - checkswdl.bat - the text is laid out to create a skull and cross bones. I've seen these with cracked software so I'm guessing something has been done to allow DIY updating instead of having to take it to a main dealer.
silverevo is online now  
Status: -
AO Member
 
alfaquo's Avatar
 
Join Date: Feb 2015
Location: Belgium
Posts: 28
Update, (not Live, from 14 to 17) was easy and was successful. (Ignition on, only)
Small adjustments in Navi (+faster) and Info (now, on-board computer)
The interior has thus received a new, small "facelift"
Thanks
alfaquo is offline  
Status: -
AO Member
 
Troogroove's Avatar
 
Join Date: Sep 2016
Location: Bournemouth
County: Dorset
Posts: 67
Quote:
Originally Posted by silverevo View Post
Is this a genuine update? The only reason I ask is if you open the file - checkswdl.bat - the text is laid out to create a skull and cross bones. I've seen these with cracked software so I'm guessing something has been done to allow DIY updating instead of having to take it to a main dealer.
The update is genuine someone who works at a dealers has just made a copy of it. The extra programs in the file are the release notes from the people that got hold of the file and a program to check the MD5 value of the ISO this is a check that allows you to see if the file has been changed from the original.

Just saves people some money for not having to pay a dealer for the update, in the US you can just download the updates and install them yourself for free.
Troogroove is offline  
Status: -
AO Member
 
silverevo's Avatar
 
Join Date: Jul 2010
Location: United Kingdom
County: Kent
Posts: 157
Quote:
Originally Posted by Troogroove View Post
The update is genuine someone who works at a dealers has just made a copy of it. The extra programs in the file are the release notes from the people that got hold of the file and a program to check the MD5 value of the ISO this is a check that allows you to see if the file has been changed from the original.

Just saves people some money for not having to pay a dealer for the update, in the US you can just download the updates and install them yourself for free.
Thats great, thanks for the explanation. I feel a bit safer doing my update now. Thanks to the original thread posters too for putting it up here.
silverevo is online now  
mru
Status: -
Newbie
 
mru's Avatar
 
Join Date: Jan 2017
Location: Not far from here
County: -Germany
Posts: 6
Garage
Did the update this morning, with the engine running. Remember to turn off Stop&Start! But if you aren't cruising, ignition is fine.
Mine is a 2016 1.4 MA with 6.5" live.
One large part of the update (9 of 9) is the DAB. I have not seen any difference; neither in performance nor in features/menus. Maybe it effects a different country, not Germany.

The added live update took several (!) attempts.

Yes the thing is faster, and reacts better to the touch inputs, but it is still the same beast.

Have I not noticed this before, or is it truely new: in the middle of the top info bar, is a circle with a leave. The colour changes based on the ECO (consumtion) value.
mru is offline  
Status: -
AO Member
 
Kidz147's Avatar
 
Join Date: Dec 2015
Location: Gloucestershire
County: UK
Posts: 47

Member car:

Giulietta QV

Software updated seamlessly and without any issues. System is so much quicker and easy to navigate, plus some extra features.
Thanks to the original poster and others for there confidence in the update.
Kidz147 is offline  
(Post Link) post #24 of 29 Old 22 Hours Ago
Status: La Dolce vita!
AO Member
 
Join Date: Mar 2011
Location: United Kingdom
County: Essex
Posts: 267
Images: 18
For those of us that haven't found a dealer that would do the update for TMC, does this enable it?
TrevB is offline  
(Post Link) post #25 of 29 Old 21 Hours Ago
Status: -
AO Member
 
Join Date: Aug 2015
County: -
Posts: 11
Quote:
Originally Posted by TrevB View Post
For those of us that haven't found a dealer that would do the update for TMC, does this enable it?
I think it does mine was on version 14 something and in TMC it showed nothing. Now it shows SILK radio station as the source so I am guessing it does now do traffic.
bartekluk is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa Giulietta

Tags
firmware , uconnect 6 5 , update

« Bulbs | - »
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome