shaking and noise from rear! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-08-07 Thread Starter
Status: -
Join Date: Aug 2007
Posts: 2

Member car:

alfa 75 2.0 ts

Help shaking and noise from rear!

Hi there,

A week ago I bought myself an Alfa 75 2.0 TS (1990). When I bought It, it had a clicking noise from the back and the clutch and gearbox seemed a bit... well tired. It looked like the clicking noise came from a broken exhaust pipe bearing. But that wasn't it. I drove it a bit hard yesterday, and of course everything went wrong.

The entire car shakes quite violently when it is standing still in neutral and when driving below 3000 rev.
It accelerates very poorly below 3000 rev., but when it's above 3000 rev. the shaking seems to go away.

The clicking noise from the back is worse, than when I bought it. When I put the clutch down the clicking noise seems to go away, or at least it isn't that loud. (But the the shaking doesn't go away).

My engine temp is around 85-95 c and has been since i bought it. It doesn't matter how I drive the car. But the meter changes all the time, so I don't know if I can trust it. Also if I turn the display light op or down the temp and gas meter does the same. I have checked the cooling system for leaks and it seems to be okay. I haven't flushed the cooling system, course I don't know were the bleed screw is located.

Please write if you have any idea of what could be the problem, or problems.

Thanks a lot.

Chris Petersen
chris p is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: shaking and noise from rear!

the vibration may well be a chunk off rubber doughnut come off, especially the rear one. Often an issue, especially on an oder car as the rubber can perish over time.

The instrument issue is probably a faulty dimmer switch, my car does the same, bash the dimmer and it goes away.

IIRC there is not a bleed screw on the rad (may be different on a 2.0 TS), just fill up via the expansion tank, start up with the cap off and the air will eventually come out.

These issues are typical of a 75 at this age, niggles, not a sign that you have bought a bad 'um, just a test before getting your badge of honour.
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

noise , rear , shaking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome