Alfa Romeo 90 Thread - Page 4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Sigh
AO Platinum Member
Marko Le Rosso's Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Fareham, Hants
Posts: 13,989
Images: 3
Originally Posted by Crystal View Post
Thanks Marko . I'll try to contact him .
You're welcome.
Marko Le Rosso is offline  
Sponsored Links
Status: -
AO Member
Crystal's Avatar
Join Date: Apr 2008
Location: Gent - Belgium
Posts: 65

Member car:


Originally Posted by paddyt View Post
It's great to see so much activity on the Alfa 90 front, I am not in a position to run a 'classic' alfa but my dad had a 90 in the mid 80s (an 85/B plate) in burgundy and despite them being extremely rare (I seem to remember being told their were only about 60 sold in the UK) there was another one in our village (decent local dealer I guess). I will never forget going to holiday to italy in it, primarily so my dad could wander round scrap yards looking for parts!
Nice story !

If you have some " old " pictures somewhere , I would be very pleased to receive them for our register .
Crystal is offline  
Status: -
Join Date: Aug 2008
Location: Ulverstone, Tasmania, Aus
Posts: 4
Originally Posted by spliglet52 View Post
I shall tell him. I would love to post photos, but neither are in a pleasing condition. One blew 5 piston rings on a rolling road, and the other is off the road due to rot. He currently has far to many projects to do anything about it, and mum has recently bort a new car so he;s using her old one (he wrecked that now tho). Seems a shame, but he has so many alfas that it's impossible to keep them all road going at any one time!!
Hi from Tasmania, Australia
Just been reading the Alfa 90 thread and would appreciate some info about your dads
Alfa 90 please.
I have a ticking noise in my engine that could possibly be stem or guide related. Could also be ring, gudgeon, piston slap, connecting rod bearings etc. Adjusted all the valve gaps to zero and still have ticking.

When your fathers car had 5 rings fail, what sort of engine noises and other symptoms did he notice?
wetprickles is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

alfa , romeo , thread

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome