Koni Shocks.... Problems? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 14-02-06 Thread Starter
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
Not Happy Koni Shocks.... Problems?

Hello all.

I am wondering if any of you have had this problem....

Was drivng along a couple of days ago and my 75 develpoed a big cluncking noise in the rear. Upon inspection i found that the threaded pin on the bottom of my shocks (which are Koni sports so we are dealing with supposedly good shocks) had cleanly sheared off.

This came as a shock as my car is not driven often and these shocks have only been in for 11000k's ... incidently they have no stone chips, no scratches or any other blemishes at all.

When i removed the shock the bottom of the shockindicates only a small amount of metal fatigue .... as the thread is about an 8-10mm thread it had maybe only 3mm of newly fatigued metal (shiny stuff)

Does anybody have a take on this situation?

Goats, A Robust solution for a high tech world!
southern75 is offline  
Sponsored Links
Status: -
Join Date: Jan 2006
Posts: 315

Member car:

alfa 75,642.9bhp

Re: Koni Shocks.... Problems?

i have had this happen on several shocks both koni and spax. is it still useable?? on some or mine i also had the metel plate that goes between the nut and rubber split allowing the nut to pull through and it was bloody irritating si i am going to install the same type as the front ones on the back by getting the brakets from demon tweeks and welding them on and then fitting the shocks.

this has also happened to me on the top to so have a check of those before its to late
alfaholic75 is offline  
(Post Link) post #3 of 3 Old 15-02-06 Thread Starter
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
Re: Koni Shocks.... Problems?

errr that sucks ..... but with so little usage?
southern75 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

koni , problems , shocks

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome