Air conditioning fan motor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-08-08 Thread Starter
Status: TS engine won't rev!
AO Member
downunder's Avatar
Join Date: Jun 2004
Location: Newcastle, Australia
Posts: 28
Air conditioning fan motor


The air conditioning blower fan on my Alfa 75 TS, (1989) is on it's last legs. It starts, but only just manages to keep going, and only if turned to high speed. It didn't even do that until I resoldered the resistors.

Does anyone have a strategy for lubricating it, maybe from the footwells? Or other suggestions? I can't even see a good place to spray anything at it. I'm not keen on pulling the dash out yet again.

Last edited by downunder; 20-08-08 at 11:25. Reason: more details
downunder is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2006
Location: Australia
County: South Australia
Posts: 13
Re: Air conditioning fan motor

A belated reply on your query!
I have a 1989 build TS and had my dash out recently to sort out various things including the heater fan. However I had no joy at all in actually getting into the fan itself (though I managed to get a couple of annoying leaves out). The casing had a few screws which I removed but the casing did not want to come apart at all. And I didn't spot any lubrication points.
My query back to you is where are the resistors? My fan speed position one just doesn't work. I replaced the switch unit which made no difference, so suspect the resistors, but have not located them.
Grange99 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

air , conditioning , fan , motor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome