75 MISFIRING/ STALLING on light throttle opening.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 09-07-08 Thread Starter
Status: -
AO Member
Join Date: Apr 2008
Posts: 23

Member car:


75 MISFIRING/ STALLING on light throttle opening..

mmmm..got an efi issue with my 88 2.5 75..this is a new one..its never done this before...ive got a slightly erratic idle, and it 'snatches' and misses just off idle as i pull away from a stand still, yet it refuses to play up under full load/throttle openings at higher rpm..????
No problem whatsoever when driven at full noise, and it seems to be going harder when im up it for the rent now, (which im quite ecstatic about, to be honest, hehe), but just doesnt want to play under light load/low rpm.. mmm..im thinkin either leads, air flow meter, or possibly an ecu fault? anyone else out there struck this problem?? im going insane with it...i hate misfires!! and especially cause its been going the best its ever gone lately..i want it back already!!!
potenziata is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: 75 MISFIRING/ STALLING on light throttle opening..

sounds like its chucking in too much fuel to me, not an issue when the throttle is wide open, but on smaller openings it creates problems. Try this link to work though the injection system to make sure its nothing like a air leak etc


purple145 is offline  
Status: -
AO Member
dgmalfa's Avatar
Join Date: Jul 2008
Posts: 14

Member car:

Vaious Alfas

Re: 75 MISFIRING/ STALLING on light throttle opening..

I would agree on that one. Try with air leak first, if it was an air-flow meter then it would more than likely not go that well, depending on fault, but if you cant find any air leaks then try air-mass meter. Check that the inlet pipe is not split anywhere after the meter and also round all the inlet area.
dgmalfa is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: 75 MISFIRING/ STALLING on light throttle opening..

Moved to 75 Tech Lounge
BigFoot is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 75, RZ, SZ

light , misfiring or , opening , stalling , throttle

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome