Heater core gone! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 1Likes
  • 1 Post By Alfa33boxer
 
Thread Tools
(Post Link) post #1 of 5 Old 10-05-16 Thread Starter
Status: I wish I had one more...
AO Member
 
Alfa33boxer's Avatar
 
Join Date: May 2008
Location: Albania
County: Tirane
Posts: 409
Images: 10
Garage
Heater core gone!

When heating is on I get fumes and also smell of antifreeze inside the cabin...so i supose the small radiator in the heater box is gone.
I got this one on eBay...
Was it worth? Seems almost impossible to find one this days heh.

Best
Elvis
Attached Images
File Type: png Screenshot_2016-05-10-15-55-06_1462907931194.png (294.1 KB, 13 views)
Alfa33boxer is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Aug 2012
Location: United Kingdom
County: Gloucestershire
Posts: 140

Member car:

alfa 33 s2

Hi, Alex, Edward or Pete at alfa sud parts may have one. I know Peter had one of me a couple of years ago to go into stock.
johnpm1967 is offline  
Status: -
AO Member
 
Join Date: Aug 2012
Location: United Kingdom
County: Gloucestershire
Posts: 140

Member car:

alfa 33 s2

Alfasud Parts and Spares

Pete has this.
johnpm1967 is offline  
 
Status: -
AO Member
 
Join Date: Jun 2005
Location: Greece
County: Attica
Posts: 173

Member car:

33 & 147

If you found it new then you are very lucky. They have been out of production from Alfa more than 10 years ago and out of production from Valeo more than 5 years ago. So you are lucky to find one new.
gritsop is offline  
(Post Link) post #5 of 5 Old 20-07-16 Thread Starter
Status: I wish I had one more...
AO Member
 
Alfa33boxer's Avatar
 
Join Date: May 2008
Location: Albania
County: Tirane
Posts: 409
Images: 10
Garage
I got it located in Thessaloniki.
I was pretty sure I was lucky to find one really.
Anyway it took me almost 3 days to get it changed on my own and alone...quite tricky but alfa-restoration.co.uk was a lot helpful. Thank you guys...

Did flush the cooling system, since both radiators are new, with some solution made by Cyclo (that i could find)...a lot of rust and debris came out. Then I put new coolant around 30/70 blue antifreeze. Car back to normal and even better. Inside I have a sauna now...haha.

All good so far...

best
Elvis
gritsop likes this.

OOO SH*T...THIS IS MY 4TH ONE
Alfa33boxer is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

Tags
core , heater

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
Replace with
For the best viewing experience please update your browser to Google Chrome