Sprint Electrics - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 29-10-07 Thread Starter
Status: -
Join Date: Oct 2007
Posts: 2
Sprint Electrics


A quick question regarding relays in a '87 1,5 Green Cloverleaf (V5 details okay but engine has inboard discs so something not quite right as I thought these had been phased out by then).
I didn't want it for the paperwork though...

On the drivers side under the bonnet, just for'd of the main fuses there is a unit marked Lucas 12V with cooling fins. There is a relay next to it and I think it's something to do with the lighting as when I plug it in the drivers side outer headlight comes on (much brighter than normal) and doesn't switch off until unplugged again. When unplugged the lights seem to work normally (sic).

The Haynes manual doesn't cover the later models and although it mentions wiper delay relays they are behind the battery on the other side.

Another question: when changing from idling to faster revs the alternator and oil pressure light come on for half a second or so, but the gauge looks okay.

Hopefully this is in the right thread as after twenty years of Alfas I've a fair few questions! Any advice gratefully received.


Alfetta_Stone is offline  
Sponsored Links
Status: -
AO Silver Member
Greek's Avatar
Join Date: Jul 2006
Location: Greece
County: -
Posts: 2,986
Images: 13
Re: Sprint Electrics

As for the model have you checked the car's number to see the actual production date?
Greek is offline  
Status: Housebuilder, slowly.
AO Silver Member
Join Date: Aug 2004
Location: United Kingdom
County: Anglesey
Posts: 1,577
Re: Sprint Electrics

Hmm, not sure what that is, but the Haynes manual should cover the 1.5 engined cars, and even the 33 derived front brakes and rear suspension. It's only realy the 1.7 engine itself that isn't covered.

Bear in mind the Haynes warning about the wiring changing dramatically from time to time so the diagrams cannot be relied upon. Having said that, I don't think the components changed that much (save for a change of manufacturer) but the wiring colours did.

Can you post a photo of it?

Buck Bundy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

electrics , sprint

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome