33 ignition - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-01-07 Thread Starter
Status: -
Join Date: Sep 2006
Location: Finland
Posts: 1
33 ignition

Hi everyone. You've got new users from Finland and sorry my bad english I've read this forum for a while, but now i have problem that haven't solved by myself My alfa 33 1.7ie has misfires under 2000rpm when engine is warm. When engine is cold or rpms more there isn't that problem. I have measured temperature sensors, fuel pressure and lambda. And checked that airleaks there can't be. I think the motor is running too lean, because cold engine runs well. Or problem could be in ignition, but how can i measure ignition parts and how the ignition timing should done. I read from autodata program that throttle position sensor's three wires should be bridged when timing is adjusted? Has anyone have that same proble or can anyone think where problem could be?
jarvay is offline  
Sponsored Links
Status: -
AO Member
stedee's Avatar
Join Date: Mar 2005
Location: West Yorks
Posts: 433
Images: 5

Member car:

alfa 33 p4

Re: 33 ignition

try here sounds like a similar problem to what you have got, i doubt it is the throttle sensor btw, i think the throttle sensor is a control for when the lambda sensor is used eg, when the throttle is flat to the floor the lambda sensor is bypassed and thats what that sensor does. also it could be the cold start sensor - i dont know where that is located though.
stedee is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome