33 headlight help? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-09-13 Thread Starter
Status: -
AO Member
Join Date: Nov 2010
Location: New Zealand
County: Otago
Posts: 23
33 headlight help?

My brother and i have just bought ourselves a low mileage series 3 33 1.5 ie (1991) the only thing stopping it from getting a warrant of fitness is the left hand headlight not working on either low beam or high beam, side lights work and the right hand light is working perfectly fine?
We have done the basic checks of bulbs, fuses and relays and all seem to be working?
Has any body else had this problem? Any help with resolving it would be great.
Cheers Adam
Soapsud82 is offline  
Sponsored Links
Status: -
AO Silver Member
LoneWolf33's Avatar
Join Date: Jun 2010
Location: Hungary
County: Budapest
Posts: 1,376
Images: 52

The ground wire / connection of the headlight connector may be burnt.
Try to connect a piece of suitable wire between the black wired connection of the headlight connector
and chassis.
LoneWolf33 is offline  
Status: -
AO Member
Join Date: Oct 2010
Location: Uruguay
County: Montevideo
Posts: 89
Images: 4

Member car:

33QV 1989

Also can Check the 2 wire harness that are connected near the battery,
Penal is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome