I've got a really stupid question.... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-10-05 Thread Starter
Status: -
AO Member
genius's Avatar
Join Date: Aug 2004
Location: 37 degrees South !
Posts: 11

Member car:

Alfa 75 3.0

Help I've got a really stupid question....

...which I already know the answer to.

I'm in a bit of a dilemma...I'm having a few "issues" at the moment and one of the probable outcomes is an engine swap to a 1712...Unfortunately I have some real time/effort invested in the heads (& some pretty funky cams) & would love to be able to use them...

...Can someone tell me definitively that I can't...
genius is offline  
Sponsored Links
Status: -
AO Silver Member
Ben_NZ's Avatar
Join Date: Feb 2005
Location: Auckland, New Zealand
Posts: 1,468
Images: 10
Re: I've got a really stupid question....

Nope, can't tell you definitively that you can't because you didn't say what motor your fancy cams and heads come out of!
I'm assuming they come out of the Alfasud Ti in your signature, which presumably has the original motor with solid lifters in. As far as I know it's possible to use the 1712 heads (bigger valves? recessed combustion chambers?) with the non-hydraulic lifters and camshafts. But I think the smaller capacity motors didn't have a recessed combustion chamber in the head, or something, so if you put those heads on your 1712 block the compression ratio will be too high?

When my last motor died I tried to investigate the 1712-head-and-solid-lifters setup, but how to achieve it seems to be a closely guarded secret among those who race boxer Alfas. They all wanted to tell me it was very difficult and they didn't know how it was done. But a friend of mine took some of the parts from my dead 1712 motor and did a dummy fit with some solid lifter bits, and found a combination of parts from each motor which appeared to work.

Disclaimer: The most I've ever done to a car is change a thermostat.

Originally Posted by 73GTVJim
"PS and you agree with Ben so you must be wrong "
Ben_NZ is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

question , stupid

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome