Well it passed....but..... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-04-13 Thread Starter
Status: -
AO Member
Join Date: Sep 2004
Location: United Kingdom
County: Norfolk
Posts: 138

Member car:

Spider S4

Well it passed....but.....

Hi all,

Not posted for a while.

Took the Sud for MOT yesterday and it passed but... I then realised in the last year I have done the grand total of..........20 miles in it. Yes twenty, bit embarrassing really, must use it more this year !

Hopefully weather will be better this year and I can get out in it more.
Toad of Toad Hall is offline  
Sponsored Links
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,958
Images: 5

Member car:

A galleon

well done...........

If you want to lend us it........ Keep it warm etc.
Elvis Presley is offline  
Status: - Update
Posts: n/a
20 miles eh, 10 each way to the test station?

nice to see it passed the mot though, ready for some sunshine now then

and welcome back, you've been missed

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome