back on the road! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-02-13 Thread Starter
Status: -
AO Member
Join Date: Apr 2009
Location: Australia
County: Tasmania
Posts: 42
back on the road!

I just got my 33 registered, after 3 years parked on the driveway then about 4 months getting it running /roadworthy its back.
I havent had this much fun driving for quite a while and my girlfriend likes it too. We were going to sell it to buy an e30 but now I want to keep it. Maybe turnbthe alfa into a track car and get an e30 for a daily.

Just 1 quick question, are the electric windiws and central locking supposed to have a 20amp fuse or should it be bigger? Its blown 2 already.
TAS16_v is offline  
Sponsored Links
Status: -
AO Silver Member
LoneWolf33's Avatar
Join Date: Jun 2010
Location: Hungary
County: Budapest
Posts: 1,376
Images: 52
The power windows has a 30A fuse integrated into the relay. The central locking has a 20A
protection in the fusebox.
LoneWolf33 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

back , road

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome