Brake pedal going hard and soft (Brake servo issues?) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-07-12 Thread Starter
Status: The Toyota broke down and the alfa didn't...
AO Member
computid's Avatar
Join Date: Dec 2011
Location: United Kingdom
County: Bedfordshire
Posts: 50
Brake pedal going hard and soft (Brake servo issues?)

Hi all,
The red minari has a couple of little issues with the brakes. The first being that I was driving it the other day, no problems. Got to my destination, came back to the car about an hour later, drove off and the pedal was a lot softer then usual. The next time I braked, it was hard, next time hard then soft again! I'm guessing that the brake servo is playing up? I don't want to replace it just yet since I'm going away with the car for a weekend in august. Can I just disconnect and plug the brake servo hose? I know the pedal will be hard but it doesn't particularly bother me.

The second issue is that when I brake hard from speed the car pulls to the left. This obviously isn't particularly desirable! I've checked the pads and they all seem fine. Could the front callipers be out of adjustment? I can always re-adjust them as per the Haynes but I want to check that these are the issue before I go to the hassle.

Any assistance is, as always, appreciated.

Bikes: GSXR 400 Gk73a, Kawasaki ZX7R
Cars: Two 1.5 Minari Road Sport Mk2's and a 1.7 16v Minari RSR

My Minari Blog
computid is offline  
Sponsored Links
Status: - Update
Posts: n/a
is one of the calipers binding causing the pads and hence the fluid to boil? that would create both the pulling and the soft pedal when you jump back in the car as the pads sitting on the discs without air goign round them can cause the fluid behind the pistons to boil creating air which gives the soft pedal, then they cool down and get better....although they don't ususally end up giving a hrad pedal

you could try disconnecting the servo as you suggest, see how that pans out

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

brake , hard , issues , pedal , servo , soft

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome