Sprint heater problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-11-04 Thread Starter
Status: Sprint locked away...
AO Member
Sud/Sprint/33 Lounge Winner 09
Join Date: Oct 2001
Location: United Kingdom
County: Cambridgeshire
Posts: 349
Images: 2
Sprint heater problem

Hi, i have a problem with the heater on my 88 1.7 Sprint. When the engine gets up to temp i switch on the blower and get hot air out the vents, but about 15-20 secs later you can feel the temperature drop until the air coming out is not even warm. I have fitted a new thermostat, flushed the cooling system and filled with new anti-freeze. I have also bled the system to make sure there is no air trapped in the heater matrix, and i get nice new green coolant coming out the outlet pipe from the matrix. I am now stuck for ideas, but it would seem that there is not enough flow through the matrix, as when i put my hand on the matrix it is too hot to touch, but if i switch the blower on i can then hold my hand on the matrix. Does anyone have an ideas as its starting to get cold now!
Greg is offline  
Sponsored Links
Status: Housebuilder, slowly.
AO Silver Member
Join Date: Aug 2004
Location: United Kingdom
County: Anglesey
Posts: 1,577
Madness Re: Sprint heater problem

So gunged up that it's beyond flushing?

I guess you will at least have to get the matrix out and flush that through on it's own, and if it's so blocked you might have to replace it.

Buck Bundy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

heater , problem , sprint

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome