Indicator woes - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Indicator woes

I dunno if anyone has had this happen to their car but the indicator on my sprint seems to be getting stuck - basicaly it wont slide up or down (to indicate left or right) without first being pulled slightly towards me. Once its past the 'hump' its fine. i cant seem to see of any reason for it being stuck so i figure it must be internal. Does anyone know what could be causing this and possibly how to fix it?
Sponsored Links
Status: missing Inverurie
AO Gold Member
Pascs's Avatar
Join Date: Apr 2002
Location: Qatar
County: Aberdeenshire
Posts: 8,063
Images: 16

Member car:

Zender 156 V6

Re: Indicator woes

If I remember correctly you should easily be able to unscrew the top and bottom cowl which covers the indicator / light stalks.

You can then see directly into the switching for the indicators etc. The whole assembly can be removed if you need to have more access.

You should be able to easily find the problem.
Pascs is offline  
Status: -
AO Silver Member
Treffynnon's Avatar
Join Date: Nov 2001
Posts: 2,193
Images: 8

Member car:

Sold :(

Re: Indicator woes

Do as Pascs says. If its internal switching though you need to be very careful when you open it up as the plastic will be very brittle from age.

Treffynnon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

indicator , woes

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome