33 occasional running problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
33 occasional running problems

i own a 33 s/w 1.7ti-seem to have running problems although the last time i drove it seemed ok? all timing correct,compressions seem ok,i think carbs are set up right,when problem occurs it sounds as though petrol is been ignited in the exhaust--which sounds a bit like its blowing but it isnt.previous owners havent looked after her so im wondering if theyve put to thick an oil in her??? or if there could be a problem with the ignition module-- any advise gratefully received
Sponsored Links
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
Sounds like a problem with the anti pollution gear is the little air pump running?
southern75 is offline  
Status: - Update
Posts: n/a
not sure she has an air pump fitted-where is it located????--it is a carb model.
Status: -
AO Member
Join Date: Feb 2002
Location: Melbourne, Australia
Posts: 335
Hi guys,
I'm pretty sure there won't be an air pump on a UK spec car. The NZ cars I used to work on were UK spec cars and didn't have any anti-pollution gear on them- went a lot better too.

In any case twin carb cars run a "pulse air" system instead of a pump, which is a big con really, it is just a one way valve in the exhaust for each cylinder that allows air into the exhaust. This system (and air pumps) simply dilute the gases and lower the concentration of Carbon Monoxide at the tailpipe. Sneaky eh?

Usually if there is a sound of fuel burnt in the exhaust it is caused by carburettor adjustment. Obviously check all the other settings are ok but it sounds like the carb tuning and balancing probably needs a bit more work.
Damon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

occasional , problems , running

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome