33 - Alternator Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
33 - Alternator Problems

Hi guys,

I was wondering if you guys could help me out with ideas on a problem i've been having.

I think my alternator might not be working as well as it should be. Every now and then, after I've stopped the car and then come back to start it again, it won't do a thing, doesn't even try to turn over.

What's the best way I can test the alternator and if it is dead, what would be a good suggestion for a replacement?

Thanks in advance.

Sponsored Links
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
Do you have a multimeter?
southern75 is offline  
Status: - Update
Posts: n/a
yep - i've got a multimeter
Status: -
AO Member
Join Date: Feb 2002
Location: Melbourne, Australia
Posts: 335
Hi Mic,

What do you have to do to start it? if the battery isn't flat it is very unlikely to be an alternator. If you jump start it and it is ok, or charge the battery and it is ok, check the alternator.

If the dash warning lights stay illuminated and the battery is ok it is more likely to be an ignition switch or starter problem. Ignition switch problems are relatively common on 33's as there is no starter relay.

It is fairly easy to test, next time it doesn't start, grab a small piece of wire and find the starter solenoid (you will probably have to remove the air cleaner) and bridge the wire between the small spade terminal and the large battery terminal (13mm nut) if the starter turns over check the ignition switch.

Then you can work out where you need to test with the multimeter... part 2 later!
Damon is offline  
Status: -
AO Silver Member
Treffynnon's Avatar
Join Date: Nov 2001
Location: surrey.uk:80
Posts: 2,193
Images: 8

Member car:

Sold :(

Here are my tips on a good replacement for the original Ducelier or Bosch that comes with the SUD/Sprint/33s.

because of site update please try here now: http://www.eminence.com.ru/helpdetails.php?id=7

That alternator has fixed all my problems with bad headlight output and has also helped the windscreen wipers.

Treffynnon is offline  
Status: -
AO Gold Member
Banflu's Avatar
Join Date: Aug 2002
Location: Malta
Posts: 6,476
does the alternator bulb light up on ignition? does it turn off after starting the engine? if yes and yes, then it means that the alternator itself is fine, but the regulator could be blown.

however as the others said i dont think the alternator's at fault - cause if that was the case it would just stop when the battery gets flat..

you could always install an ammeter in series with the alternator output to see if any current is flowing wink
Banflu is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

alternator , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome