Help with faults - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
ian campbell
Status: - Update
Posts: n/a
Help with faults

Hi all
As i posted in a previous post i aquired a 33 1.5 ie for free,it had sat in a drive for 3 years.
The good news is it passed it,s mot with nothing major needing done but it has a couple of faults i hope someone can help me with.
The temp gauge dosen,t work,how do i check the gauge,sender etc and where is the sender.
I am scared to run it for too long incase the fan dosen,t come on,how do i check that.
The heater fan fuse keeps blowing i disconnected the plug on the fan and now the fuse is ok but the fan still goes on but flat out how does this happen and how do i fix it.
Thanks in advance
Sponsored Links
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
the temp sensor is in the radiator on the left hand side, if it has buggered up it may be due to a fault elsewhere a short which is blowing your fuse
southern75 is offline  
Status: -
AO Member
Join Date: Feb 2002
Location: Melbourne, Australia
Posts: 335
Hi Ian,

The temperature Gauge sender on a 1.7ie is actually mounted in one of the the inlet manifolds- I think it is the left hand one and has one wire attached. You may have to remove the main inlet/plenum chamber to access it.

If you short it out the gauge should go to full scale- If it does it is probably a sender fault- if it doesn't- check your wiring and gauge cluster.

There is a second sender on the ie motors with a two wire plug which is for the fuel injection system- this is independant of the gauge or cooling fan.

The sender in the radiator is just for the cooling fan, you can test it by putting a thermometer in the expansion tank with the engine running and making sure the fan kicks in at around 85-90 degrees.

If you work through it step by step you will work it out- maybe if you download the wiring diagrams it will help you solve the problem easier.

Damon is offline  
ian campbell
Status: - Update
Posts: n/a
Thanks Damon
I noticed the sender on the manifold and wondered what it was,there is also a sender about central on the block it to has a single wire to it,the sender on the radiator is on the right(facing front)is there any way to check these with an ohm meter

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome