Is this normal? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 16-03-03 Thread Starter
Status: The mad poll maker
AO Platinum Member
Pasi's Avatar
Join Date: Mar 2003
Location: Finland
County: -
Posts: 12,381
Images: 8
Is this normal?

When steering the tires to end positions the cars RPM's drop and it starts to make a faint "squeaky" noise...
And It doesn't seem to matter whether the car is moving or still.

We're talking about a 33 1,7IE '91

Is there something wrong or is this normal?
Pasi is offline  
Sponsored Links
Status: -
AO Gold Member
Banflu's Avatar
Join Date: Aug 2002
Location: Malta
Posts: 6,476
i think this is normal. mind you, you shouldnt be doing that too often cause it could harm your system. what is hapenning IMO is, the power steering pump is pumping more oil to steer the wheels, when they are on full lock. so the pump will be very hard to turn (cause no oil will flow, or very little.) thus the RPM would go down.

am i right Hoy? wink
Banflu is offline  
Status: -
AO Member
Join Date: Nov 2001
Location: Sydney Australia
Posts: 489
my 3 cars with p/s all do that
only 1 of em is an alfa
southern75 is offline  
Status: Wyrd is Life
AO Gold Member
Stori's Avatar
Join Date: Nov 2002
County: -
Posts: 11,590
Just a friendly comment.
It is not good practice to try and turn the steering wheel unless you are moving(even if only just moving). Otherwise the high load you put on the steering gear will lead to premature failure frown
Stori is offline  
Status: - Update
Posts: n/a
My car's also doing that when he's not moving, and I think that's normal... When your wheels are in the end position, the steering pump has to pump a lot of oil to try to move the wheels any further... ofcourse this is not good for your steering system.
Status: - Update
Posts: n/a
Any movement of the wheel causes the engine to drop in revs but full lock will give the noise as the system cannot go any further. As stated above, doing this for long periods (more than a couple of seconds) may harm the system.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome