No brakes! Need help desperatly!!!:( - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
No brakes! Need help desperatly!!!:(


I'm Going completly mad...
like I've said previously, I drive a '92 Alfa 33 1.7 16v QV with 4 discs allround and ABS
Problem is, that, Recently I discovered that the only one rear wheel (left one) was braking... The right caliper has just siezed... The mechanic I went to told me that it has no repair, they tried fitting a repair kit, but the bugger won't budge...
This is a mega problem, because a new one costs about 500 euros, and the don't know if they can find one, because they out of stock here in Portugal.
I haven't been able to find one in a scrap yard. I can only find 33's with rear drums...
Does anyone have a clue how to fix this problem?

I'm getting pretty desperate, because the car's anual inspection is due this month...
I love this car and I don't want to loose it...

best regards

Sponsored Links
Status: - Update
Posts: n/a
Hi Sergio

I'dont think a new caliper is about 500 euro. I think if you can get one by a car (tool) shop, you can by one for something of 150/200 euro's.

Status: - Update
Posts: n/a
Thanks Remco,

The price I got was from Alfa.
I haven't tried a spare shop yet, but i don't believe they have anything... I might be wrong...

Thanks again

Status: - Update
Posts: n/a
Hi again,

I getting really desperate...
I found a second hand caliper in a scrapyard, which appears to be functional...
I mechanic has fitted it, and has got the handbrake horking (on the rear right wheel), but the wheel doesn't brake at all when the pedal is pressed. The say the brake fluid gets through the lines but doesent activate the pump. they also say the fluid pressure is the same on both rear wheels...
It just does not brake!
Does any body know what might be causing this?
Might it have any relation with the ABS system?

Please, if any body knows anything, please tell me.

Every body is telling me that i shouldn't have bought an alfa...
I really don't want to believe them!

Best regards, and awaiting a reply

yours sincerly

Status: - Update
Posts: n/a
Hi there if you have abs there is a relay that makes the abs works, its located just in front under the hood next to the heater i can give u extracts from a workshopmanual but its in dutch ca translate it dough if u want, just contact me
Status: - Update
Posts: n/a

thanks, any heplp is welcome
please send me those extracts, if possible, to my email

thank you very much

buy the way have you heard anything as strange as this happening to a 33 16v?

thanks again
Status: cornea come l'inferno
AO Silver Member
Hoygaard's Avatar
Join Date: Apr 2002
Location: Denmark
County: Kobenhavn
Posts: 4,156

Member car:

156 GTA SW

Hi Vroom

Did the mechanic actually measure the brake fluid pressure at the rear calipers? If the pressure is the same on both wheels, and the handbrake actually make the piston move, it should work. I do not believe the mechanic checked the pressure. Have you had the brake pressure regulator valve checked, it could be buggered. Or it could be the brake hose, sometimes the rubber on the inside can come loose, and act as trap, when pressure is applied. When no pressure is present, fluid can still pass thru though.

All the best

Hoygaard is offline  
Status: - Update
Posts: n/a
Hi Hoygaard

The mechanic told me they checked the brake fluid pressure at the rear, and it was the same...
I don't now if they checked the pressure regulator valve...

Thanks alot

All the best,


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

brakes , desperatly

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome