Gearbox oil riddle. (Spacenut's thread) - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Drive it Like you Stole it ;)
Join Date: Dec 2008
Location: Cyprus
County: Nicosia
Posts: 10,277
Images: 27

Its a mind cracker innit ?

I just thought about something else, because I'm still not convinced that its the angle that causes the problem ( sorry about that )...quite the opposite actually, I am convinced that it isnt the angle's fault

on my box ( or on the speedo chain mech better ) there was an "o" ring that kept the oil inside the gearbox and was craked ! It leaked from there down to the housing of the gearbox for a long time untill I figured out that it was craked and leaking from there.
Could this be the case for you as well ?
This way, the same random error could happen twice because you used the same speedo cable and mech as you did on your last gearbox

I just found the picture on google and painted a red arrow to show you what I mean.

Last edited by Supercharged16v; 27-09-10 at 09:49.
Supercharged16v is offline  
Sponsored Links
Status: Car in bits again...
AO Silver Member
Spacenut's Avatar
Join Date: Feb 2007
Location: Hampshire, UK
Posts: 1,566
Images: 14

Member car:

Nova T33/1.5

Hi Supercharged - hmm, nice try, but I don't think this is the cause of my problem. Somehow the gearbox oil is getting onto the driveshaft, then it gets thrown off the brake disc.

This is how it looked after a run earlier this year (I de-gunked all the oil off before the run).

You can see my electronic speedo sensor, but the mounting flange and circlip are not visible. The speedo drive pinion is mounted at an angle and is therefore above and behind the halfshaft. If oil was coming out here it would have to dribble forwards as well as down, crossing the halfshaft flange onto the halfshaft, then down onto the disc, which seems unlikely. The reason why my old gearbox had to be scrapped was because the old speedo drive was corroded into the casing... even though there was no evidence of oil around the speedo drive there was still gearbox oil around the halfshaft. So I don't think it was/is a leaking speedo pinion oil seal.

Another shot showing how the oil gets thrown off the brake disc when on the move. There is a slick of oil painted on the underside of my engine cover louvre immediately above, and a dark line of oil around the back of the flywheel bellhousing. If I clean this oil off, no more issues from the leak site until I drive somewhere.

Just for comparison, this is what the nearside disc looks like - bone dry.

Sorry about the lens flare on the pictures, but they were only taken for information.

And thanks for your suggestions Super, your input is greatly appreciated. I will get this problem licked (preferably before the next MoT)!


Alfanauts are GO!!!
Spacenut is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

gearbox , oil , riddle , spacenut , thread

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome