33 series 3 rusty spots (for me) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-05-09 Thread Starter
Status: The mad poll maker
AO Platinum Member
Pasi's Avatar
Join Date: Mar 2003
Location: Finland
County: -
Posts: 12,381
Images: 8
33 series 3 rusty spots (for me)

Stripped most of my 33's interior out to check the rust damage of the floor.

Here are the spots that needed to be welded (were rusted through):

Drivers floor:
Had some rust in the seam connecting the middle and front part and some welding had been done by the previous owner to where the jacking point is (was). The drain "plug" was welded shut by the previous owner. also I did see some rust below the pillar structure below the drivers seat, but can't get to it before I can get the car up and the anti-rust compound taken off.

Passenger side floor:
The drain plug was rusted away (almost nothing left) and a small see-through rust damage at the seam (same as drivers side). Bought a new plug and welded shut the seam. Same kind of rust damage below the seat as in the drivers side.

Drivers side back floor:
Small rust hole just behind the front seat (at the door side) and a HUGE 10x30cm hole on the right side of the floor (almost at the center fixing of the drivers seat). Drain plug was welded shut by previous owner.

Passenger side back floor:
Almost all of the right side front seat fixing was gone. Needed some clever welding to get it sorted. The floor itself was in good condition. Drain plug was welded shut by previous owner.

Huge rust damages to the shock absorber chamber, both inside and outside. Few randomish see through spots at the back floor and below the spare wheel. Drainpipe below the spare wheel was in OK condition, so just gave it a nice phosphor acid path, and it's as good as new. Wheel arch on the drivers side has some issues. at the top ... some of the petrol tanks pipes that come in the car, have had their original hole enlarged by rust. Also the tanks fill pipe fixing spot has been corroded through and seems to be held together by the anti-rust compound.

F.Y.I. This is a left hand drive car we are talking about.

Got MOT this week and have absolutely no chance of passing it (not because of rust as it's "all" fixed). I'm hoping to get the 1 month time to fix things, as some of the parts I need haven't arrived yet

What Do You Have When A Lawyer Is Buried Up To His Neck In Sand? Not Enough Sand.

- ✂- - - - - - - - - - - CUT HERE - - - - - - - - - - - ✂ -
This post is provided "As-is" without any warranty, not even the implied warranty of making any sense what so ever.
Pasi is offline  
Sponsored Links
Status: in polishing stage
AO Member
Matt.K's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Torfaen
Posts: 315
Re: 33 series 3 rusty spots (for me)

Did you do the welding work yourself??

And we need pictures - we like pictures
Matt.K is offline  
(Post Link) post #3 of 3 Old 06-05-09 Thread Starter
Status: The mad poll maker
AO Platinum Member
Pasi's Avatar
Join Date: Mar 2003
Location: Finland
County: -
Posts: 12,381
Images: 8
Re: 33 series 3 rusty spots (for me)

Can't weld a **** my self

A friend of mine did it and he used to work as a professional welder for 10 years (quit few years ago).

I did take some pictures, and I can post them if I remember.

took the car to MOT today... only some of the reamining rusty spots and handbrake low grip failed... otherwise it was in mint condition

More welding will happen on Friday this week, and the brake thingy is just upto me tightening the adjustment nut inside the car
Pasi is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

rusty , series , spots

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome