Front lights not working...please HELP! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-04-09 Thread Starter
Status: I wish I had one more...
AO Member
Alfa33boxer's Avatar
Join Date: May 2008
Location: Albania
County: Tirane
Posts: 400
Images: 10
Help Front lights not working...please HELP!

Hi everyone!
I have another problem with my 33 Imola...
Some 2 weeks ago the front lights sometimes used to stay on even after turning off the car and lights switch....yesterday the lights went off and I still have no lights at all when I turn the key on (both positions)!!!

I think it could be the lights relay, but only if I knew where is located...!
Please, can anybody tell me where the relay is, or if it's not the relay what could be the problem???
The fuses are OK.
and than again with Italian electrics ...

Alfa33boxer is offline  
Sponsored Links
Status: Drive it Like you Stole it ;)
Join Date: Dec 2008
Location: Cyprus
County: Nicosia
Posts: 10,277
Images: 27
Re: Front lights not working...please HELP!

Italian electrics on the imola are actually Bosch so.... its again with the German electrics

Sounds like its a shorted relay problem.
If you dont know how to check a relay the easiest way is to take them out - from the fusebox not the engine bay - one by one and see what happens. There should be one for the fog lights, one for the normal lights, one for horn and one for hazard lights. Central locking, air condition and fuel pump relays are located elsewhere.
So if you turn all these on and take out relays you can do the canceling method.

You can also change one with the other. Take one that you know it works, just make sure to check if its an 87a or 87b relay and change with the same kind.

Last , if the lights stay on again , and the relay is shorted, it could be a bit hot !
Supercharged16v is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

front , lights , workingplease

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome