sud rad fan switch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 31-03-09 Thread Starter
Status: A.C.A.B
AO Silver Member
melv's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: South Yorkshire
Posts: 1,220

Member car:


sud rad fan switch

just bought a new rad fan switch, put it in an ran the car ,the temp went way past 80, fan never kicked in, i then wired the fan straight up to battery to see if it was the fan , that was ok.

so is there a way of testing the new switch?

what temp does it show on your car when the fan kicks in?

my be i didnt wait long enough before i turn it off.
melv is offline  
Sponsored Links
Status: -
AO Silver Member
Fluffyduff's Avatar
Join Date: Nov 2006
Location: Ireland
County: Louth
Posts: 2,788
Images: 2

Member car:

33 16v

Re: sud rad fan switch

I had to change mine a few months back and the new one doesn't kick in till 95degrees. Not impressed at all.

If you want to check if its working hook it up to a multimeter and check for continuity in a bowl of boiling water. (watch the handies!)
Fluffyduff is offline  
Status: -
AO Member
GOTOGT's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Shropshire
Posts: 118
Images: 24
Re: sud rad fan switch

When I changed mine I had the same problem, only to find there was nothing wrong with the old one - it was just a poor earth connection. On my sud ti the earth is taken from one of the headlamp surround fixings and it corroded.
GOTOGT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 33, Sud & Sprint

fan , rad , sud , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome